QA@IT

そのギモンは、あなただけのもの?

ITエンジニアが日々遭遇する課題やトラブルはたいてい、1人だけが出合うものではありません。QA@ITで質問・回答を共有しませんか?

タグ rvm で絞り込んだ結果 - 解除

現在、Capistrano3とRails4.0を使って、RVMでRubyがインストールされたサーバ上に、Railsのデプロイを行いたいと考えています。 しかしながら、Rails等のPATHがうまく通らず、command not foundになってしまいます。 具体的な状況を説明させていただきます。 CapsistranoでPATHが取っている事を確認したいため、以下のようなdeploy.rb...

現在、Rails4でcapistrano3でRVMでrubyがインストールされた環境に、デプロイ環境を構築しようとしているのですが、エラーが出て困っています。 エラー内容は cap aborted! LoadError: cannot load such file -- rvm/capistrano config/deploy.rb:19:in `<top (required)>' という内...

$ rvm use system ruby 1.8.7 (2013-06-27 patchlevel 374) [x86_64-linux] $ rvm gemset list_all gemsets for ruby-1.8.7-p374 (found in /home/username/.rvm/gems/ruby-1.8.7-p374) => (default) global gems...

When I try to install ruby 1.8.7 with rvm(1.22.15) like rvm install 1.8.7, it showed me: Searching for binary rubies, this might take some time. No binary rubies available for: ubuntu/12.04/x86_64/...

今回仕事で指定のruby on rails環境をローカルに構築する必要があり、設定を進めています。 ローカル環境はMacBook Pro Intel Core i5にMac OS X Lion(10.7.5)です。 rvmをインストールし、指定されているバージョンのruby(1.9.2-p290)をインストールしようとしたのですが、 以下のようなエラーが起こり、インストールができません。(ユ...

ruby 2.0.0-p0 がリリースされ、いろいろと新しいものを試すにも良いタイミングだと思います。 そこで rvm や rbenv やそれ以外のものも含めて、複数バージョンの ruby を切り替えたり、デプロイ先のサーバーでの ruby のバージョンを指定したりするのに、最近は何がおすすめなのかを知りたいです。 メリットやデメリットなどの理由も含めておすすめをお願いします。

現在、Rubyのバージョン切り替えにRVMを使っていますが、最近はrbenvも人気のようです。違いは何ですか?