QA@IT

IIS6.0で動作中のASPプログラムをIIS8.0のASP4.5もしくはクラシックへ移行した際に実行できない

2035 PV

お世話になります。

現在VS2005で作成したASPをwindowsserver2003のIIS6.0で動作させています。
今回サーバ交換にともないASPをwindowsserver2012のIIS8.0上で動作させようと試みてます。
しかし
以下のエラーで実行ができません。


パーサー エラー メッセージ: ファイルまたはアセンブリ 'ADODB, Version=7.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'、またはその依存関係の 1 つが読み込めませんでした。指定されたファイルが見つかりません。

たしかにADOを利用していますがIIS8でも実行できる方法があるのでしょうか?

MDAC_TYP.EXEをいれたりしましたがだめなようです。

調べるとOfficeをインストールすれば改善できるとの事ですが確証がなくできておりません。
もし最適な方法があればと思います。

プログラムの修正はなるべく避けたいと考えております。

ご迷惑をおかけしますがよろしくお願いします。

  • クラシック ASP or ASP.NET、ADO or ADO.NET どっちなんですか? まずそれをはっきりさせてください。あと、「IIS8.0のASP4.5もしくはクラシック」って何ですか? 用語はきちんと使っておられるでしょうか? -
ウォッチ

この質問への回答やコメントをメールでお知らせします。