QA@IT

CentOS7.0でネットワーク起動でエラーが出る件

36388 PV

CentOS7.0をクリーンインストールしました。ネットワークの初期化で/var/log/messagesに以下のlogが
吐き出されます。ネットワーク自体は支障なく利用でき、ssh、samba、vsftpが問題なく動作しています。
これが正しい動作なのか否かご助言等ございましたら、お願い致します。

NetworkManager[673]: startup complete
systemd: Started Network Manager Wait Online.
systemd: Starting LSB: Bring up/down networking...
NetworkManager[673]: parsing /etc/sysconfig/network-scripts/ifcfg-lo ...
network: ループバックインターフェイスを呼び込み中 '/etc/sysconfig/network-scripts/ifcfg-lo' ファイルを読み込めませんでした。
NetworkManager[673]: parsing /etc/sysconfig/network-scripts/ifcfg-lo ...
network: '/etc/sysconfig/network-scripts/ifcfg-lo' ファイルを読み込めませんでした。
NetworkManager[673]: parsing /etc/sysconfig/network-scripts/ifcfg-lo ...
network: '/etc/sysconfig/network-scripts/ifcfg-lo' ファイルを読み込めませんでした。
NetworkManager[673]: parsing /etc/sysconfig/network-scripts/ifcfg-lo ...
network: '/etc/sysconfig/network-scripts/ifcfg-lo' ファイルを読み込めませんでした。
network: [ OK ]
network: インターフェース enp2s0 を活性化中: エラー: 接続 'XXXXXX'用のデバイスが見つかりません.
network: [失敗]
systemd: network.service: control process exited, code=exited status=1
systemd: Failed to start LSB: Bring up/down networking.
systemd: Unit network.service entered failed state.
aries-x systemd: Starting Network.
systemd: Reached target Network.

それぞれのifcfgは以下の通りです。

ifcfg-lo

DEVICE=lo
IPADDR=127.0.0.1
NETMASK=255.0.0.0
NETWORK=127.0.0.0
# If you're having problems with gated making 127.0.0.0/8 a martian,
# you can change this to something else (255.255.255.255, for example)
BROADCAST=127.255.255.255
ONBOOT=yes
NAME=loopback

ifcfg-enp2s0

TYPE=Ethernet
BOOTPROTO=none
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
NAME=XXXXXXX
UUID=28c42d7c-7ba5-4a9b-818e-bf4a3ff6f8a0
DEVICE=enp2s0
ONBOOT=yes
DNS1=192.168.0.1
IPADDR=192.168.0.2
PREFIX=24
GATEWAY=192.168.0.1
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes

#systemctl
network.service loaded failed failed LSB: Bring up/down networking

回答

バグ報告がCentOS Bug Trackerに上がっているようですね。ステータスは2015-11-14 04:10 UTC時点ではResolution=openになっています。既知のバグでしょうか。

0007351: Service network failes to start - CentOS Bug Tracker
https://bugs.centos.org/view.php?id=7351

ifcfg-loの方はファイルに下記の行を追加すればunrecognized typeとして無視されるようです(単なる回避策?)。

TYPE=loopback

ifcfg-enp2s0の方は、報告をざっと見た感じ結構ばらつきがあるようですが、皆さんどうにか解決していらっしゃるようにも見受けられます。

  • 「systemctl enable NetworkManager-wait-online.service」で直った
  • /etc/nsswitch.confの変更で直った
  • ファイルに「HWADDR=...」を追加したら直った
  • Realtek NIC driverの問題(ドライバをr8169からr8168に変更したら直った)
  • ファイルに「NM_CONTROLLED=yes」を追加したら直った
  • 等々
編集 履歴 (0)
  • ご回答ありがとうございます。バグですか。出て1年くらいではまだまだ枯れるのには早いのでしょうか。 -
ウォッチ

この質問への回答やコメントをメールでお知らせします。