QA@IT

FacebookのJavaScript SDK v2.0 で新デザイン(v2.3)のウィジェットを利用できる?

2609 PV

Facebookのウィジェットをページに実装したいのですが、
SDKを変更せずに新しいウィジェットを利用することは出来るのでしょうか。

例えばですが、現在提供されているSDKはv2.3ですが、ウィジェットのプラグインの部分のみを抜き出し、v2.0で利用することは出来るのでしょうか。

提供されているPage Plugin(2015/04現在:V2.3)

    <div id="fb-root"></div>
    <script>(function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//connect.facebook.net/ja_KS/sdk.js#xfbml=1&version=v2.3";
      fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'facebook-jssdk'));</script>
    <div class="fb-page" data-href="https://www.facebook.com/facebook" data-hide-cover="false" data-show-facepile="true" data-show-posts="false"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/facebook"><a href="https://www.facebook.com/facebook">Facebook</a></blockquote></div></div>

利用しようと考えるPage Plugin(V2.0 .fb-pageを2.3のものから流用)

    <div id="fb-root"></div>
    <script>(function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//connect.facebook.net/ja_JP/sdk.js#xfbml=1&version=v2.0";
      fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'facebook-jssdk'));</script>
    <div class="fb-page" data-href="https://www.facebook.com/facebook" data-hide-cover="false" data-show-facepile="true" data-show-posts="false"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/facebook"><a href="https://www.facebook.com/facebook">Facebook</a></blockquote></div></div>

また、このような活用が難しい場合同ページ上にV2.0 V2.3のSDKを共存させることは出来るんでしょうか。

ウォッチ

この質問への回答やコメントをメールでお知らせします。