QA@IT

MacOSでEclipse + Tomcatの設定がうまくいかない。

12971 PV

EclipseからTomcatを使用するための設定がうまくいきません。。。
EclipseにTomcatのボタンが追加されません。

MacOS(10.9.5)上でEclipse(4.4.1)を用いてTomcat(7.0.57)の立ち上げを試みています。
しかし、EclipseからTomcatを使用するための設定がうまくいきません。。。
URLよりEclipseでTomcatを使用するためのプラグインがうまくいかないのです。。。

http://www.eclipsetotale.com/tomcatPlugin.html
から、「tomcatPluginV331.zip」をダウンロードし、解凍して出てきた「com.sysdeo.eclipse.tomcat_3.3.1.jar」をeclipse/plugins/にコピーしてEclipseを起動しましたが、Tomcat起動用のボタンが追加されません(添付した画像)。

どこか設定やファイルがおかしいのでしょうか??

ただ、どの参考書やサイトを見てもファイルは「tomcatPluginV331.zip」を解凍すると「com.sysdeo.eclipse.tomcat_3.3.1」フォルダが
それをeclipse/plugins/にコピーすると書いてあるのが気がかりです。
自分の場合は解凍しても、[.jar]ファイルしか出てきません。

ちなみにターミナルにおいて、
startup.sh
で起動し、
http://localhost:8080
でTomcatの画面まで出てくるところまで成功はしました。

わかる方いらっしゃいましたら、解答よろしくお願いします。
Tomcat.jpg

回答

最近のEclipseはeclipse/pluginsフォルダではなく、eclipse/dropinsフォルダに配置されたプラグインが読み込まれます。そちらにいれてみてください。

編集 履歴 (0)

ご返事ありがとうございます。
zip形式でeclipse/plugins/に入れて試してみましたが、やはりだめです。

パスの件ですが、
添付した通りです。
tomcatを/usr/localに入れているので、あっていると思うのですが。。。

__________2014-12-20_1.06.01.png

編集 履歴 (0)

そこのtomcatボタンを最近使ってないので、ちょっと以下の部分だけ。

ただ、どの参考書やサイトを見てもファイルは「tomcatPluginV331.zip」を解凍すると「com.sysdeo.eclipse.tomcat_3.3.1」フォルダが
それをeclipse/plugins/にコピーすると書いてあるのが気がかりです。

たしかに tomcatPluginV331.zip の中身は com.sysdeo.eclipse.tomcat_3.3.1.jarファイルで間違いありません(今DLして見ました)。
補足するとすれば、jarファイルはzip形式なので、拡張子をzipにすれば解凍できます。そうすればフォルダとして配置する事ができますが、クラスパスにjarもディレクトリも指定できるように、jarの中も探索してくれますから特に解凍する必要はないんじゃないかと思います。(でも解凍するだけですから、気になるなら試していまうのも手です)


ところでtomcatのインストールPATHは間違いなく指定できてるんでしょうか?

編集 履歴 (1)
ウォッチ

この質問への回答やコメントをメールでお知らせします。