QA@IT
«質問へ戻る

syntax hilightの修正

5599
本文
 こんにちは、今回はherokuデプロイ時のsecret_key_baseエラーについて質問させて頂きます。 
 gemのversionはそれぞれ 
+```gem
 rails 4.1.0 
 pg 0.15.1 
 ruby 2.1.3
+```
 です。 
 
 以前までrailsのバージョン4.0でしかデプロイしたことがなく、今回、4.1に上げ、 
 config/secrets.yml 
+```
 production:
   secret_key_base: <%= ENV["SECRET_KEY_BASE"] %>
+```
 と書き、herokuにデプロイしたのですが、heroku openすると 
 
+
+```
 Internal Server Error 
 
 Missing secret_key_base for 'production' environment, set this value in config/secrets.yml 
 
+```
+
 と言われてしまいます。 
 
-公式どおり heroku config:set SECRET_KEY_BASE=ruby -rsecurerandom -e "puts SecureRandom.hex(64)" ともしましたがエラーは変化しません。 
+公式どおり `heroku config:set SECRET_KEY_BASE=ruby -rsecurerandom -e "puts SecureRandom.hex(64)"` ともしましたがエラーは変化しません。 
 
-config/secrets.ymlに書くだけじゃダメなのでしょうか?? 
+`config/secrets.yml`に書くだけじゃダメなのでしょうか?? 
 ローカルでのproductionは問題なく動いています。
 
 よろしくお願いします。

rails herokuデプロイの際のMissing secret_key_base

こんにちは、今回はherokuデプロイ時のsecret_key_baseエラーについて質問させて頂きます。
gemのversionはそれぞれ

rails 4.1.0 
pg 0.15.1 
ruby 2.1.3

です。

以前までrailsのバージョン4.0でしかデプロイしたことがなく、今回、4.1に上げ、
config/secrets.yml

production:
  secret_key_base: <%= ENV["SECRET_KEY_BASE"] %>

と書き、herokuにデプロイしたのですが、heroku openすると

Internal Server Error 

Missing secret_key_base for 'production' environment, set this value in config/secrets.yml 

と言われてしまいます。

公式どおり heroku config:set SECRET_KEY_BASE=ruby -rsecurerandom -e "puts SecureRandom.hex(64)" ともしましたがエラーは変化しません。

config/secrets.ymlに書くだけじゃダメなのでしょうか??
ローカルでのproductionは問題なく動いています。

よろしくお願いします。

こんにちは、今回はherokuデプロイ時のsecret_key_baseエラーについて質問させて頂きます。 
gemのversionはそれぞれ 
```gem
rails 4.1.0 
pg 0.15.1 
ruby 2.1.3
```
です。 

以前までrailsのバージョン4.0でしかデプロイしたことがなく、今回、4.1に上げ、 
config/secrets.yml 
```
production:
  secret_key_base: <%= ENV["SECRET_KEY_BASE"] %>
```
と書き、herokuにデプロイしたのですが、heroku openすると 


```
Internal Server Error 

Missing secret_key_base for 'production' environment, set this value in config/secrets.yml 

```

と言われてしまいます。 

公式どおり `heroku config:set SECRET_KEY_BASE=ruby -rsecurerandom -e "puts SecureRandom.hex(64)"` ともしましたがエラーは変化しません。 

`config/secrets.yml`に書くだけじゃダメなのでしょうか?? 
ローカルでのproductionは問題なく動いています。

よろしくお願いします。

質問を投稿

rails herokuデプロイの際のMissing secret_key_base

こんにちは、今回はherokuデプロイ時のsecret_key_baseエラーについて質問させて頂きます。
gemのversionはそれぞれ
rails 4.1.0
pg 0.15.1
ruby 2.1.3
です。

以前までrailsのバージョン4.0でしかデプロイしたことがなく、今回、4.1に上げ、
config/secrets.yml
production:
secret_key_base: <%= ENV["SECRET_KEY_BASE"] %>
と書き、herokuにデプロイしたのですが、heroku openすると

Internal Server Error

Missing secret_key_base for 'production' environment, set this value in config/secrets.yml

と言われてしまいます。

公式どおり heroku config:set SECRET_KEY_BASE=ruby -rsecurerandom -e "puts SecureRandom.hex(64)" ともしましたがエラーは変化しません。

config/secrets.ymlに書くだけじゃダメなのでしょうか??
ローカルでのproductionは問題なく動いています。

よろしくお願いします。

こんにちは、今回はherokuデプロイ時のsecret_key_baseエラーについて質問させて頂きます。 
gemのversionはそれぞれ 
rails 4.1.0 
pg 0.15.1 
ruby 2.1.3
です。 

以前までrailsのバージョン4.0でしかデプロイしたことがなく、今回、4.1に上げ、 
config/secrets.yml 
production:
  secret_key_base: <%= ENV["SECRET_KEY_BASE"] %>
と書き、herokuにデプロイしたのですが、heroku openすると 

Internal Server Error 

Missing secret_key_base for 'production' environment, set this value in config/secrets.yml 

と言われてしまいます。 

公式どおり heroku config:set SECRET_KEY_BASE=ruby -rsecurerandom -e "puts SecureRandom.hex(64)" ともしましたがエラーは変化しません。 

config/secrets.ymlに書くだけじゃダメなのでしょうか?? 
ローカルでのproductionは問題なく動いています。

よろしくお願いします。