QA@IT
«回答へ戻る

5599
   nyaos.putenv('PATH', 'C:\\RailsInstaller\\Ruby2.0.0\\bin;' .. os.getenv('PATH'))
 ```
 
+`nyaos.putenv`は 3.3.1_0 からですので、それ以前ですとこの方法は使えないかもしれません。

以下ではだめですか?

  -- set PATH+=C:\RailsInstaller\Ruby2.0.0\bin
  nyaos.putenv('PATH', 'C:\\RailsInstaller\\Ruby2.0.0\\bin;' .. os.getenv('PATH'))

nyaos.putenvは 3.3.1_0 からですので、それ以前ですとこの方法は使えないかもしれません。

以下ではだめですか?

```lua
  -- set PATH+=C:\RailsInstaller\Ruby2.0.0\bin
  nyaos.putenv('PATH', 'C:\\RailsInstaller\\Ruby2.0.0\\bin;' .. os.getenv('PATH'))
```

`nyaos.putenv`は 3.3.1_0 からですので、それ以前ですとこの方法は使えないかもしれません。

回答を投稿

以下ではだめですか?

  -- set PATH+=C:\RailsInstaller\Ruby2.0.0\bin
  nyaos.putenv('PATH', 'C:\\RailsInstaller\\Ruby2.0.0\\bin;' .. os.getenv('PATH'))
以下ではだめですか?

```lua
  -- set PATH+=C:\RailsInstaller\Ruby2.0.0\bin
  nyaos.putenv('PATH', 'C:\\RailsInstaller\\Ruby2.0.0\\bin;' .. os.getenv('PATH'))
```