QA@IT
«回答へ戻る

2
 
 webサービスをIISへ設定して、上記の状態になったのですが、この状態でサーバ側でもクライアントの
 プログラムでWebサービスを参照して指定しようとするとエラーになって設定できない状態です
-
-Web.Configに問題があるのでしょうか?
-ちなみに中身は
-"<?xml version="1.0"?>
-"<configuration>
-"  <configSections>
-"    <sectionGroup name="applicationSettings"
-    type="System.Configuration.ApplicationSettingsGroup,
-     System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
-      <section name="SMS2WebService.My.MySettings" 
-         type="System.Configuration.ClientSettingsSection, 
-          System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"
-           requirePermission="false"/>
-    </sectionGroup>
-  </configSections>
-  <connectionStrings>
-    <add name="SMS2WebService.My.MySettings.ConnectionString" 
-      connectionString="Data Source=xxxx:1521/xxxx:User
-        ID=;Password=;Unicode=True" providerName="System.Data.OracleClient"/>
-  </connectionStrings>
-  <system.web>
-    <compilation debug="true" strict="false" explicit="true" targetFramework="4.0"/>
-    <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID"/>
-  </system.web>
-  <system.serviceModel>
-    <behaviors>
-      <serviceBehaviors>
-        <behavior>
-          <serviceMetadata httpGetEnabled="true"/>
-          <serviceDebug includeExceptionDetailInFaults="true"/>
-        </behavior>
-      </serviceBehaviors>
-    </behaviors>
-    <serviceHostingEnvironment multipleSiteBindingsEnabled="true"/>
-  </system.serviceModel>
-  <system.webServer>
-    <modules runAllManagedModulesForAllRequests="true"/>
-  </system.webServer>
-  <applicationSettings>
-    <SMS2WebService.My.MySettings>
-      <setting name="OenStaffCode" serializeAs="String">
-        <value>99999</value>
-      </setting>
-      <setting name="LogLevel" serializeAs="String">
-        <value>0</value>
-      </setting>
-    </SMS2WebService.My.MySettings>
-  </applicationSettings>
-</configuration>
-です。

VisualStudioでクラサバのアプリをクリックワンスで構築して、DBとのやり取り部分をWebサービスで行う
という形をとりました。

webサービスをIISへ設定して、上記の状態になったのですが、この状態でサーバ側でもクライアントの
プログラムでWebサービスを参照して指定しようとするとエラーになって設定できない状態です

VisualStudioでクラサバのアプリをクリックワンスで構築して、DBとのやり取り部分をWebサービスで行う
という形をとりました。

webサービスをIISへ設定して、上記の状態になったのですが、この状態でサーバ側でもクライアントの
プログラムでWebサービスを参照して指定しようとするとエラーになって設定できない状態です

2
 
 Web.Configに問題があるのでしょうか?
 ちなみに中身は
-<?xml version="1.0"?>
-<configuration>
-  <configSections>
-    <sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
-      <section name="SMS2WebService.My.MySettings" type="System.Configuration.ClientSettingsSection, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false"/>
+"<?xml version="1.0"?>
+"<configuration>
+"  <configSections>
+"    <sectionGroup name="applicationSettings"
+    type="System.Configuration.ApplicationSettingsGroup,
+     System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
+      <section name="SMS2WebService.My.MySettings" 
+         type="System.Configuration.ClientSettingsSection, 
+          System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"
+           requirePermission="false"/>
     </sectionGroup>
   </configSections>
   <connectionStrings>
-    <add name="SMS2WebService.My.MySettings.ConnectionString" connectionString="Data Source=ski-egg-db:1521/MASTRANS.SKI;User ID=SKI;Password=hbttr4741;Unicode=True" providerName="System.Data.OracleClient"/>
+    <add name="SMS2WebService.My.MySettings.ConnectionString" 
+      connectionString="Data Source=xxxx:1521/xxxx:User
+        ID=;Password=;Unicode=True" providerName="System.Data.OracleClient"/>
   </connectionStrings>
   <system.web>
     <compilation debug="true" strict="false" explicit="true" targetFramework="4.0"/>

VisualStudioでクラサバのアプリをクリックワンスで構築して、DBとのやり取り部分をWebサービスで行う
という形をとりました。

webサービスをIISへ設定して、上記の状態になったのですが、この状態でサーバ側でもクライアントの
プログラムでWebサービスを参照して指定しようとするとエラーになって設定できない状態です

Web.Configに問題があるのでしょうか?
ちなみに中身は
"<?xml version="1.0"?>
"
"
"



























99999


0




です。

VisualStudioでクラサバのアプリをクリックワンスで構築して、DBとのやり取り部分をWebサービスで行う
という形をとりました。

webサービスをIISへ設定して、上記の状態になったのですが、この状態でサーバ側でもクライアントの
プログラムでWebサービスを参照して指定しようとするとエラーになって設定できない状態です

Web.Configに問題があるのでしょうか?
ちなみに中身は
"<?xml version="1.0"?>
"<configuration>
"  <configSections>
"    <sectionGroup name="applicationSettings"
    type="System.Configuration.ApplicationSettingsGroup,
     System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
      <section name="SMS2WebService.My.MySettings" 
         type="System.Configuration.ClientSettingsSection, 
          System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"
           requirePermission="false"/>
    </sectionGroup>
  </configSections>
  <connectionStrings>
    <add name="SMS2WebService.My.MySettings.ConnectionString" 
      connectionString="Data Source=xxxx:1521/xxxx:User
        ID=;Password=;Unicode=True" providerName="System.Data.OracleClient"/>
  </connectionStrings>
  <system.web>
    <compilation debug="true" strict="false" explicit="true" targetFramework="4.0"/>
    <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID"/>
  </system.web>
  <system.serviceModel>
    <behaviors>
      <serviceBehaviors>
        <behavior>
          <serviceMetadata httpGetEnabled="true"/>
          <serviceDebug includeExceptionDetailInFaults="true"/>
        </behavior>
      </serviceBehaviors>
    </behaviors>
    <serviceHostingEnvironment multipleSiteBindingsEnabled="true"/>
  </system.serviceModel>
  <system.webServer>
    <modules runAllManagedModulesForAllRequests="true"/>
  </system.webServer>
  <applicationSettings>
    <SMS2WebService.My.MySettings>
      <setting name="OenStaffCode" serializeAs="String">
        <value>99999</value>
      </setting>
      <setting name="LogLevel" serializeAs="String">
        <value>0</value>
      </setting>
    </SMS2WebService.My.MySettings>
  </applicationSettings>
</configuration>
です。

回答を投稿

VisualStudioでクラサバのアプリをクリックワンスで構築して、DBとのやり取り部分をWebサービスで行う
という形をとりました。

webサービスをIISへ設定して、上記の状態になったのですが、この状態でサーバ側でもクライアントの
プログラムでWebサービスを参照して指定しようとするとエラーになって設定できない状態です

Web.Configに問題があるのでしょうか?
ちなみに中身は
<?xml version="1.0"?>






























99999


0




です。

VisualStudioでクラサバのアプリをクリックワンスで構築して、DBとのやり取り部分をWebサービスで行う
という形をとりました。

webサービスをIISへ設定して、上記の状態になったのですが、この状態でサーバ側でもクライアントの
プログラムでWebサービスを参照して指定しようとするとエラーになって設定できない状態です

Web.Configに問題があるのでしょうか?
ちなみに中身は
<?xml version="1.0"?>
<configuration>
  <configSections>
    <sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
      <section name="SMS2WebService.My.MySettings" type="System.Configuration.ClientSettingsSection, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false"/>
    </sectionGroup>
  </configSections>
  <connectionStrings>
    <add name="SMS2WebService.My.MySettings.ConnectionString" connectionString="Data Source=ski-egg-db:1521/MASTRANS.SKI;User ID=SKI;Password=hbttr4741;Unicode=True" providerName="System.Data.OracleClient"/>
  </connectionStrings>
  <system.web>
    <compilation debug="true" strict="false" explicit="true" targetFramework="4.0"/>
    <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID"/>
  </system.web>
  <system.serviceModel>
    <behaviors>
      <serviceBehaviors>
        <behavior>
          <serviceMetadata httpGetEnabled="true"/>
          <serviceDebug includeExceptionDetailInFaults="true"/>
        </behavior>
      </serviceBehaviors>
    </behaviors>
    <serviceHostingEnvironment multipleSiteBindingsEnabled="true"/>
  </system.serviceModel>
  <system.webServer>
    <modules runAllManagedModulesForAllRequests="true"/>
  </system.webServer>
  <applicationSettings>
    <SMS2WebService.My.MySettings>
      <setting name="OenStaffCode" serializeAs="String">
        <value>99999</value>
      </setting>
      <setting name="LogLevel" serializeAs="String">
        <value>0</value>
      </setting>
    </SMS2WebService.My.MySettings>
  </applicationSettings>
</configuration>
です。