QA@IT

Cisco 1812の設定について

3539 PV

Cisco1812の設定がうまくいかず、困ってます。
固定IP8のプロバイダを契約しており、下記設定を投入しても、VLAN1側からの通信ができません。

切り分けのため、VLAN10側のグローバルIPで試したところ、インターネット通信もできております。
(PCに直接グローバルIPを入れてみました。DNSも手動入力しました。)

VLAN1側からインターネット通信するために、何か必要な設定はありますでしょうか。

教えて頂ければ幸いです。

【要件】
1.固定IP8個のUnnumbered接続
2.VLAN1(PRIVATE)/VLAN10(GLOBAL)にセグメントを分割

※VLAN1に対してOverloadできず困っております。

【Config】

interface FastEthernet0
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1

interface Vlan1
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1414

interface Vlan10
ip address AAA.BBB.CCC.DDD 255.255.255.248
ip nat outside
ip virtual-reassembly in
ip tcp adjust-mss 1414

interface Dialer1
ip unnumbered Vlan10
ip mtu 1454
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname @
ppp chap password 0 ****

ip nat inside source list 100 interface Vlan10 overload
access-list 100 permit ip 192.168.0.0 0.0.0.255 any
dialer-list 100 protocol ip permit

ip route 0.0.0.0 0.0.0.0 Dialer1

回答

「ip nat inside source list ***」には標準ACLを指定しないといけないようです。
access-list 100を標準ACLに書き換えると解消しないでしょうか。
http://www.cisco.com/en/US/docs/ios-xml/ios/ipaddr/command/ipaddr-i3.html#wp1284532593

編集 履歴 (0)
  • ご回答ありがとうございます。
    ためしましたが、改善には至っておりません。
    -
  • 了解です。お力になれず申し訳ない… -

実機を触ったことがないので見当違いかもしれないのですが、
pppoeを使っているFastEthernet0とvlan10の対応付けはできてるんでしょうか。

編集 履歴 (0)
  • お返事が遅くなり、申し訳ございません。

    interface Dialer1
    ip unnumbered Vlan10

    上記で出来ていると思いますが。。。
    -
  • すみません、見落としていました…。
    別途思いついた点を回答しています。
    -

最終的に、下記コンフィグと同一のCiscoコンフィグを作成したいと思っています。

【YAMAHA Config】

ip route default gateway pp 1
ip lan1 address 192.168.100.1/24
ip lan2 address AAA.BBB.CCC.DD0/29 【GLOBAL-IP】※DMZとして利用
ip lan3 nat descriptor 1
pp select 1
pp always-on on
pppoe use lan3
pppoe auto disconnect off
pp auth accept chap
pp auth myname **** ****
ppp lcp mru on 1454
ppp ipcp msext on
ip pp nat descriptor 1
pp enable 1
nat descriptor type 1 masquerade
nat descriptor address outer 1 AAA.BBB.CCC.DD1【Overload】
nat descriptor address inner 1 192.168.100.1-192.168.100.254【Overload】
nat descriptor static 1 1 AAA.BBB.CCC.DD2=192.168.100.2 1【NAT】
dhcp service server
dhcp server rfc2131 compliant except remain-silent
dhcp scope 1 192.168.100.128-192.168.100.254/24
dns server pp 1

編集 履歴 (0)
ウォッチ

この質問への回答やコメントをメールでお知らせします。