QA@IT
«回答へ戻る

5599
 
 2.5.8-4.el5.centos  は 5.9用のExtraパッケージと書いてますね。 
 5.3に不要かどうかはさておき、なんにしてもx86_64がポツンといるのは不思議です。
+
+----
+
+参考までに、インストールして大して使ってないCentOS5.6 32bit で今インストールしてみた結果は以下の様になりました。
+(phpは入ってないです。)
+
+```
+[root@localhost ~]# yum install libmcrypt-devel
+Loaded plugins: fastestmirror
+Loading mirror speeds from cached hostfile
+ * base: ftp.iij.ad.jp
+ * epel: ftp.iij.ad.jp
+ * extras: ftp.iij.ad.jp
+ * updates: ftp.iij.ad.jp
+base                                                     | 1.1 kB     00:00
+epel                                                     | 3.6 kB     00:00
+epel/primary_db                                          | 3.1 MB     00:00
+extras                                                   | 2.1 kB     00:00
+updates                                                  | 1.9 kB     00:00
+updates/primary_db                                       | 549 kB     00:00
+Setting up Install Process
+Resolving Dependencies
+--> Running transaction check
+---> Package libmcrypt-devel.i386 0:2.5.8-4.el5.centos set to be updated
+--> Processing Dependency: libmcrypt = 2.5.8-4.el5.centos for package: libmcrypt-devel
+--> Processing Dependency: libmcrypt.so.4 for package: libmcrypt-devel
+--> Running transaction check
+---> Package libmcrypt.i386 0:2.5.8-4.el5.centos set to be updated
+--> Finished Dependency Resolution
+
+Dependencies Resolved
+
+================================================================================
+ Package               Arch       Version                    Repository    Size
+================================================================================
+Installing:
+ libmcrypt-devel       i386       2.5.8-4.el5.centos         extras        10 k
+Installing for dependencies:
+ libmcrypt             i386       2.5.8-4.el5.centos         extras       116 k
+
+Transaction Summary
+================================================================================
+Install       2 Package(s)
+Upgrade       0 Package(s)
+
+Total download size: 126 k
+Is this ok [y/N]:
+
+Downloading Packages:
+(1/2): libmcrypt-devel-2.5.8-4.el5.centos.i386.rpm       |  10 kB     00:00
+(2/2): libmcrypt-2.5.8-4.el5.centos.i386.rpm             | 116 kB     00:00
+--------------------------------------------------------------------------------
+Total                                           669 kB/s | 126 kB     00:00
+Running rpm_check_debug
+Running Transaction Test
+Finished Transaction Test
+Transaction Test Succeeded
+Running Transaction
+  Installing     : libmcrypt                                                1/2
+  Installing     : libmcrypt-devel                                          2/2
+
+Installed:
+  libmcrypt-devel.i386 0:2.5.8-4.el5.centos
+
+Dependency Installed:
+  libmcrypt.i386 0:2.5.8-4.el5.centos
+
+Complete!
+
+```

このエラーの通りlibmcryptをyumでインストールしてみました。

これの結果が見たいです(インストールできてるか知りたいです)。

もう一度インストールしてみるなどしてそのログを見せてください。
(インストール済みパッケージ表示でも構いません、楽な方で)

yum install libmcrypt-devel

ですかね?


http://rpmfind.net/linux/rpm2html/search.php?query=libmcrypt-devel

2.5.8-4.el5.centos は 5.9用のExtraパッケージと書いてますね。
5.3に不要かどうかはさておき、なんにしてもx86_64がポツンといるのは不思議です。


参考までに、インストールして大して使ってないCentOS5.6 32bit で今インストールしてみた結果は以下の様になりました。
(phpは入ってないです。)

[root@localhost ~]# yum install libmcrypt-devel
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: ftp.iij.ad.jp
 * epel: ftp.iij.ad.jp
 * extras: ftp.iij.ad.jp
 * updates: ftp.iij.ad.jp
base                                                     | 1.1 kB     00:00
epel                                                     | 3.6 kB     00:00
epel/primary_db                                          | 3.1 MB     00:00
extras                                                   | 2.1 kB     00:00
updates                                                  | 1.9 kB     00:00
updates/primary_db                                       | 549 kB     00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package libmcrypt-devel.i386 0:2.5.8-4.el5.centos set to be updated
--> Processing Dependency: libmcrypt = 2.5.8-4.el5.centos for package: libmcrypt-devel
--> Processing Dependency: libmcrypt.so.4 for package: libmcrypt-devel
--> Running transaction check
---> Package libmcrypt.i386 0:2.5.8-4.el5.centos set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package               Arch       Version                    Repository    Size
================================================================================
Installing:
 libmcrypt-devel       i386       2.5.8-4.el5.centos         extras        10 k
Installing for dependencies:
 libmcrypt             i386       2.5.8-4.el5.centos         extras       116 k

Transaction Summary
================================================================================
Install       2 Package(s)
Upgrade       0 Package(s)

Total download size: 126 k
Is this ok [y/N]:

Downloading Packages:
(1/2): libmcrypt-devel-2.5.8-4.el5.centos.i386.rpm       |  10 kB     00:00
(2/2): libmcrypt-2.5.8-4.el5.centos.i386.rpm             | 116 kB     00:00
--------------------------------------------------------------------------------
Total                                           669 kB/s | 126 kB     00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : libmcrypt                                                1/2
  Installing     : libmcrypt-devel                                          2/2

Installed:
  libmcrypt-devel.i386 0:2.5.8-4.el5.centos

Dependency Installed:
  libmcrypt.i386 0:2.5.8-4.el5.centos

Complete!

> このエラーの通りlibmcryptをyumでインストールしてみました。

これの結果が見たいです(インストールできてるか知りたいです)。

もう一度インストールしてみるなどしてそのログを見せてください。
(インストール済みパッケージ表示でも構いません、楽な方で)

`yum install libmcrypt-devel`

ですかね?


----

http://rpmfind.net/linux/rpm2html/search.php?query=libmcrypt-devel

2.5.8-4.el5.centos  は 5.9用のExtraパッケージと書いてますね。 
5.3に不要かどうかはさておき、なんにしてもx86_64がポツンといるのは不思議です。

----

参考までに、インストールして大して使ってないCentOS5.6 32bit で今インストールしてみた結果は以下の様になりました。
(phpは入ってないです。)

```
[root@localhost ~]# yum install libmcrypt-devel
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: ftp.iij.ad.jp
 * epel: ftp.iij.ad.jp
 * extras: ftp.iij.ad.jp
 * updates: ftp.iij.ad.jp
base                                                     | 1.1 kB     00:00
epel                                                     | 3.6 kB     00:00
epel/primary_db                                          | 3.1 MB     00:00
extras                                                   | 2.1 kB     00:00
updates                                                  | 1.9 kB     00:00
updates/primary_db                                       | 549 kB     00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package libmcrypt-devel.i386 0:2.5.8-4.el5.centos set to be updated
--> Processing Dependency: libmcrypt = 2.5.8-4.el5.centos for package: libmcrypt-devel
--> Processing Dependency: libmcrypt.so.4 for package: libmcrypt-devel
--> Running transaction check
---> Package libmcrypt.i386 0:2.5.8-4.el5.centos set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package               Arch       Version                    Repository    Size
================================================================================
Installing:
 libmcrypt-devel       i386       2.5.8-4.el5.centos         extras        10 k
Installing for dependencies:
 libmcrypt             i386       2.5.8-4.el5.centos         extras       116 k

Transaction Summary
================================================================================
Install       2 Package(s)
Upgrade       0 Package(s)

Total download size: 126 k
Is this ok [y/N]:

Downloading Packages:
(1/2): libmcrypt-devel-2.5.8-4.el5.centos.i386.rpm       |  10 kB     00:00
(2/2): libmcrypt-2.5.8-4.el5.centos.i386.rpm             | 116 kB     00:00
--------------------------------------------------------------------------------
Total                                           669 kB/s | 126 kB     00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : libmcrypt                                                1/2
  Installing     : libmcrypt-devel                                          2/2

Installed:
  libmcrypt-devel.i386 0:2.5.8-4.el5.centos

Dependency Installed:
  libmcrypt.i386 0:2.5.8-4.el5.centos

Complete!

```

5599
 `yum install libmcrypt-devel`
 
 ですかね?
+
+
+----
+
+http://rpmfind.net/linux/rpm2html/search.php?query=libmcrypt-devel
+
+2.5.8-4.el5.centos  は 5.9用のExtraパッケージと書いてますね。 
+5.3に不要かどうかはさておき、なんにしてもx86_64がポツンといるのは不思議です。

このエラーの通りlibmcryptをyumでインストールしてみました。

これの結果が見たいです(インストールできてるか知りたいです)。

もう一度インストールしてみるなどしてそのログを見せてください。
(インストール済みパッケージ表示でも構いません、楽な方で)

yum install libmcrypt-devel

ですかね?


http://rpmfind.net/linux/rpm2html/search.php?query=libmcrypt-devel

2.5.8-4.el5.centos は 5.9用のExtraパッケージと書いてますね。
5.3に不要かどうかはさておき、なんにしてもx86_64がポツンといるのは不思議です。

> このエラーの通りlibmcryptをyumでインストールしてみました。

これの結果が見たいです(インストールできてるか知りたいです)。

もう一度インストールしてみるなどしてそのログを見せてください。
(インストール済みパッケージ表示でも構いません、楽な方で)

`yum install libmcrypt-devel`

ですかね?


----

http://rpmfind.net/linux/rpm2html/search.php?query=libmcrypt-devel

2.5.8-4.el5.centos  は 5.9用のExtraパッケージと書いてますね。 
5.3に不要かどうかはさておき、なんにしてもx86_64がポツンといるのは不思議です。

5599
 
 もう一度インストールしてみるなどしてそのログを見せてください。
 (インストール済みパッケージ表示でも構いません、楽な方で)
+
+`yum install libmcrypt-devel`
+
+ですかね?

このエラーの通りlibmcryptをyumでインストールしてみました。

これの結果が見たいです(インストールできてるか知りたいです)。

もう一度インストールしてみるなどしてそのログを見せてください。
(インストール済みパッケージ表示でも構いません、楽な方で)

yum install libmcrypt-devel

ですかね?

> このエラーの通りlibmcryptをyumでインストールしてみました。

これの結果が見たいです(インストールできてるか知りたいです)。

もう一度インストールしてみるなどしてそのログを見せてください。
(インストール済みパッケージ表示でも構いません、楽な方で)

`yum install libmcrypt-devel`

ですかね?

回答を投稿

このエラーの通りlibmcryptをyumでインストールしてみました。

これの結果が見たいです(インストールできてるか知りたいです)。

もう一度インストールしてみるなどしてそのログを見せてください。
(インストール済みパッケージ表示でも構いません、楽な方で)

> このエラーの通りlibmcryptをyumでインストールしてみました。

これの結果が見たいです(インストールできてるか知りたいです)。

もう一度インストールしてみるなどしてそのログを見せてください。
(インストール済みパッケージ表示でも構いません、楽な方で)