QA@IT
«回答へ戻る

回答を投稿

エラーの出力をみると、...ruby-1.9.3-p194/gems/json-1.7.5... と ruby 1.9.3 のライブラリを参照しているのに、ruby 1.8.7 (2011-12-28 patchlevel 357) [universal-darwin11.0] と ruby 1.8.7 が実行されているのが気になります。

これが原因かはわかりませんが、post-commit 1 行目 (shebang) の /usr/bin/env ruby を ruby 1.9.3 のフルバス (/Users/yahsan2/.rvm/rubies/ruby-1.9.3-p194/bin/ruby かな?) に変更してみてはいかがでしょうか?

エラーの出力をみると、`...ruby-1.9.3-p194/gems/json-1.7.5...` と ruby 1.9.3 のライブラリを参照しているのに、`ruby 1.8.7 (2011-12-28 patchlevel 357) [universal-darwin11.0]` と ruby 1.8.7 が実行されているのが気になります。

これが原因かはわかりませんが、post-commit 1 行目 (shebang) の `/usr/bin/env ruby` を ruby 1.9.3 のフルバス (`/Users/yahsan2/.rvm/rubies/ruby-1.9.3-p194/bin/ruby` かな?) に変更してみてはいかがでしょうか?