QA@IT

Cisco1812jでWebサーバーを公開するには

4562 PV

お世話になります。
現在、旧ルーターからCisco1812jへ乗り換えて設定をしています。
以前のルーターで、WEBサーバーを公開するためにNAT変換とフィルタリングの設定を行っておりました。

Ciscoの1812jでは、様々なサイト様を参照し、インターネット接続する所までは問題無く出来ましたが、
WAN(固定IP)へのアクセスをLAN内の特定のサーバーに飛ばしたいのですが、NATの設定やアクセス
リストの設定を行ってもポートを解放する事ができません。

コンフィグは下記のコンフィグになります。

!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
service sequence-numbers
!
hostname router
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200
logging console critical
enable secret 5 XXXXXXXXXXXXXXXXXXXXXXXXXXX.
!
no aaa new-model
clock timezone JST 9
!
crypto pki trustpoint TP-self-signed-4207133228
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4207133228
revocation-check none
rsakeypair TP-self-signed-4207133228
!
!
crypto pki certificate chain TP-self-signed-4207133228
certificate self-signed 01
省略
quit
dot11 syslog
no ip source-route
!
!
ip cef
!
!
no ip bootp server
ip domain name router.jp
ip name-server XX.XXX.XXX.XXX
ip name-server XXX.XXX.XXX.XXX
!
multilink bundle-name authenticated
!
!
username administrator privilege 15 secret 5 XXXXXXXXXXXXXXXXXXXXXXXXXXXX
!
!
archive
log config
hidekeys
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
class-map type inspect match-any CCP-Voice-permit
match protocol h323
match protocol skinny
match protocol sip
class-map type inspect match-any ccp-cls-insp-traffic
match protocol cuseeme
match protocol dns
match protocol ftp
match protocol h323
match protocol https
match protocol icmp
match protocol imap
match protocol pop3
match protocol netshow
match protocol shell
match protocol realmedia
match protocol rtsp
match protocol smtp extended
match protocol sql-net
match protocol streamworks
match protocol tftp
match protocol vdolive
match protocol tcp
match protocol udp
class-map type inspect match-all ccp-insp-traffic
match class-map ccp-cls-insp-traffic
class-map type inspect match-any ccp-cls-icmp-access
match protocol icmp
match protocol tcp
match protocol udp
class-map type inspect match-all ccp-invalid-src
match access-group 100
class-map type inspect match-all ccp-icmp-access
match class-map ccp-cls-icmp-access
class-map type inspect match-all ccp-protocol-http
match protocol http
!
!
policy-map type inspect ccp-permit-icmpreply
class type inspect ccp-icmp-access
inspect
class class-default
pass
policy-map type inspect ccp-inspect
class type inspect ccp-invalid-src
drop log
class type inspect ccp-protocol-http
inspect
class type inspect ccp-insp-traffic
inspect
class type inspect CCP-Voice-permit
inspect
class class-default
pass
policy-map type inspect ccp-permit
class class-default
!
zone security out-zone
zone security in-zone
zone-pair security ccp-zp-self-out source self destination out-zone
service-policy type inspect ccp-permit-icmpreply
zone-pair security ccp-zp-in-out source in-zone destination out-zone
service-policy type inspect ccp-inspect
zone-pair security ccp-zp-out-self source out-zone destination self
service-policy type inspect ccp-permit
!
!
!
interface BRI0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
encapsulation hdlc
ip route-cache flow
shutdown
!
interface FastEthernet0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet1
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
shutdown
duplex auto
speed auto
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-FE 2$$ES_LAN$$FW_INSIDE$
ip address 192.168.12.3 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
zone-member security in-zone
ip route-cache flow
ip tcp adjust-mss 1452
!
interface Dialer1
description $FW_OUTSIDE$
ip address negotiated
ip mtu 1454
ip nat outside
ip virtual-reassembly
zone-member security out-zone
encapsulation ppp
ip tcp adjust-mss 1414
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname XXXXXXXXXXXXXXXXX
ppp chap password XXXXXXXXXXXXXXXXX
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip dns view default
dns forwarder XX.XXX.XXX.XXX
dns forwarder XXX.XXX.XXX.XXX
ip dns server
ip nat inside source list 101 interface Dialer1 overload
!
logging trap debugging
access-list 100 remark CCP_ACL Category=128
access-list 100 permit ip host 255.255.255.255 any
access-list 100 permit ip 127.0.0.0 0.255.255.255 any
access-list 101 permit ip 192.168.12.0 0.0.0.255 any
dialer-list 1 protocol ip permit
no cdp run
!
!
!
!
!
!
control-plane
!
banner exec ^C


上記のインターネットに繋がるだけのコンフィグにあるサイトを参考に下記コマンドを実行しました。
ip nat inside source list 101 interface Dialer1 overload
ip nat inside source static tcp 192.168.12.153 80 interface Dialer1 80
ip nat pool LAN 192.168.12.153 192.168.12.153 netmask 255.255.255.0
ip nat inside source list 102 pool LAN

また、CCPも使用して実施してみましたが、解放できませんでした。
Cisco1812jをルーターにしてWebサーバーを公開するには実際にどのような設定が必要なのでしょうか。

以上、よろしくお願いいたします。

回答

CCPを導入して開放を行ってみてはどうでしょうか。

CCPで設定したところ、一発で開放され、公開することが出来ました。

編集 履歴 (0)

追加:
申し訳ございません。下記コマンドも投入しております。

access-list 101 permit ip any host 192.168.12.153

編集 履歴 (0)
  • あれ、投稿済みの質問はご自身であれば編集できますよ。あと、リスト部分などは ``` で囲むとブロックとして扱われて見やすくなると思います。Markdown記法の使い方をご参考にどうぞ http://qa.atmarkit.co.jp/docs/markdown -
  • すみません。バグで更新できません。 -
ウォッチ

この質問への回答やコメントをメールでお知らせします。