QA@IT

gitで"git pull"できない

11787 PV

git pullを行おうとすると

$ git pull
You are not currently on a branch, so I cannot use any
'branch..merge' in your configuration file.
Please specify which branch you want to merge with on the command
line and try again (e.g. 'git pull ').
See git-pull(1) for details.

が表示され、git pullが出来なくなってしまいます。

表示に従い git pull origin master を行うとpullができますが、毎回これを入力するのは不便です。
どうにか出来ないでしょうか?

  • ちなみに、submoduleで登録したリポジトリで起きました。
    submodule使うと起こるんですかね…?
    -

回答

ウォッチ

この質問への回答やコメントをメールでお知らせします。