QA@IT

gemsetでbundleがつかえない

2349 PV

現在railsで開発を行っているのですが、gemsetがうまく使えなくてこまっています。
具体的にはgemsetを使った場合に他のgemがインストールできないのです。

ーー開発環境ーー
Ubuntu
rvm 1.14.1
rvm list >> =* ruby-1.9.3-p194
ーーエラー再現手順ーー
1 rvm gemset use Hoge
2 cd railsproject(Gemfileがあるrailsプロジェクトです。)
3 bundle install

ーーエラー内容ーー
ERROR: Gem bundler is not installed, run gem install bundler first.

ーーエラーに対して行った対策ーー
1 gem install bundler
結果:
ERROR: While executing gem ... (Errno::EACCES)
Permission denied - /home/ユーザ名/.gem/specs

2 sudo gem install bundler
結果:
1 gem installed
Installing ri documentation for bundler-1.1.4...
Installing RDoc documentation for bundler-1.1.4...

3 bundle
ERROR: Gem bundler is not installed, run gem install bundler first.

ーーgem listーー

*** LOCAL GEMS ***

以上です。何か気づいた点があればご指摘いただけると助かります。

回答

First,runvi ~/.bashrc,add this to the end:source ~/.rvm/scripts/rvm.
Second,runsource ~/.bashrc.
Last,rungem install bundler.

編集 履歴 (0)

bundler 使っているのならそもそも gemset 不要なのでは?

編集 履歴 (0)
ウォッチ

この質問への回答やコメントをメールでお知らせします。