QA@IT

Xcode4.3をインストールしたが、rvmでrubyのコンパイルができない

2531 PV

rubyのコンパイルを行うにはXcodeが必要だということなので、Xcode4.3をインストールしたがコンパイルで失敗します。

回答

Xcodeのメニューから「Preferences...」を選んで、その中の「Downloads」タブにある「Command Line Tools」をインストールしてみたらどうでしょうか。

編集 履歴 (0)

対象となる Ruby のバージョンがわかりませんが、gcc が必要なら Command Line Tools for Xcode, gcc-4.2 が必要なら Homebrew の apple-gcc42 使う必要があります。どちらが必要かは Ruby のバージョンによって異なります。

編集 履歴 (0)

Command Line Tools for Xcodeも入れると良いそうです。

編集 履歴 (0)
ウォッチ

この質問への回答やコメントをメールでお知らせします。