QA@IT

もしdevkit無しでRubyを使うとどうなるか?

339 PV

Ruby初心者です。Windows10(64ビット)を使っております。

RubyInstallerからRuby2.4か2.5を何度かインストールしようとしたのですが、通信が悪いのか失敗し続けました(またやってみるつもりではあります)。なお2.6をインストールしようとしていないのは実は上級者向けであると別のサイトで教えられたからです。

そこで、ruby-lang.orgに書いてあった方法の1つとしてActiveScriptRubyがありましたので試しにインストールしたところ出来ました。ちゃんとRuby2.4のx64のものをです。
しかし、こちらはエクスプローラで確認するとdevkitが入っていないようなのです。
C:/Program Files/Ruby-2.4-x64
で「d」や「de」で検索して確認しました。

そこで質問なのですが、devkitが無いままRubyを扱うことになるとどのような問題や不便があるのでしょうか?
また、devkitはRubyInstallerの一覧のページから個別にインストール出来るようですがそれらは古いバージョンのもの(Ruby 2.0、2.3)しかないようで、それらはやはりバージョンが違うのでやめておいたほうがよろしいでしょうか?あるいはdevkitを2.4にアップデートすることはできないでしょうか?

どうかご回答をよろしくお願い致します。

ウォッチ

この質問への回答やコメントをメールでお知らせします。