QA@IT

SQLServerのレプリケーションの互換性レベルについて

10503 PV

異なるバージョン間のSQLServerトランザクションレプリケーションについての質問となります。

<環境>
・パブリッシャー:SQLServer2008
・ディストリビューター:ローカルディストリビュータを用いている
・サブスクライバー:SQLServer2014

上記の環境で、プッシュトランザクションレプリケーションを行う想定なのですが、
パブリッシャを作成し、サブスクライバーを作成しようと追加したところ
「選択したサブスクライバーは、選択されたパブリケーションに関して最低限のバージョン互換性レベルを満たしていません。」
とエラーになってしまいます。

下記のページではSQLServer2014と2005には互換性がないことが記載されておりますが

SQLSever2008から2014ではレプリケーションは行えないのでしょうか?
https://docs.microsoft.com/ja-jp/sql/relational-databases/replication/deprecated-features-in-sql-server-replication?view=sql-server-2014

※相互のDBサーバーにはhostsにサーバー名を記載し、相互からアクセス可能なように設定はしております。

ウォッチ

この質問への回答やコメントをメールでお知らせします。